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9:00-10:10 | 1. Overview of Eclipse + Introduction to PTP Greg
and PTP + Eclipse basics
+ Configuring Resource
Managers & setup
10:10-10:30 | 2. Creating and Running +PTP project creation Beth
MPI Programs +New project wizards
+PTP Runtime Perspective
10:30-10:45 | Break
10:45-11:10 | 3. Parallel Language + MPI, OpenMP analysis Beth
Development Tools (PLDT) features
11:10-11:45 | 4. Parallel Debugger + Debug Perspective, Greg
breakpoints, variables,
stepping, etc.
11:45-12:15 | 5. Advanced Eclipse and + CVS, Makefiles, autoconf, Greg
PTP features Search, Refactoring, UPC,
Remote debugging, MPICH2,
IBM PE & LoadLeveler
12:15-12:30 | 6. Other, Summary, + Perf. tools, website, mailing Beth
Wrapup lists, more info, participation




Module 1: Overview of Eclipse
and PTP

+ Objective
+ To introduce the Eclipse platform and PTP
+ To learn the basics of Eclipse
+ Contents
+ What is Eclipse? Who is using Eclipse?
+ What is PTP?
+ Eclipse basics
+ Configuring a Resource Manager

Module 1 PTP Tutorial 1-0

What is Eclipse?

+ A vendor-neutral open source development
platform

+ A universal platform for tool integration

+ Plug-in based framework to create, integrate
and utilize software tools

Java C/C++/Fortran Test and
Development Development Performance Parallel Tools
Tools Tools Tools
Platform
User
e Debug Update Help Team
Equinox
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Eclipse Platform

+ Core frameworks and services with which all

plug-in extensions are created

+ Represents the common facilities required by

most tool builders:

+ Workbench user interface

+ Project model for resource management

+ Portable user interface libraries (SWT and JFace)

+ Automatic resource delta management for
incremental compilers and builders

+ Language-independent debug infrastructure

+ Distributed multi-user versioned resource
management (CVS supported in base install)
+ Dynamic update/install service
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Plug-ins

Java Development Tools (JDT)

Plug-in Development Environment (PDE)
C/C++ Development Tools (CDT)

Parallel Tools Platform (PTP)

Fortran Development Tools (Photran)

Test and Performance Tools Platform (TPTP)
Business Intelligence and Reporting Tools (BIRT)
Web Tools Platform (WTP)

Data Tools Platform (DTP)

Device Software Development Platform (DSDP)
Many more...

Module 1 PTP Tutorial 1-3




Eclipse PTP: Parallel Tools Platform
http://eclipse.org/ptp

Coding & Analysis Launching & Monitoring

]

e e o

N
T

mil: © N——

Performance Tuning

Debugging
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Eclipse History

+ Originally developed by Object Technology
International (OTI) and purchased by IBM for
use by internal developers

+ Released to open-source community in 2001,
managed by consortium

+ Eclipse Public License (EPL)
+ Based on IBM Common Public License (CPL)

+ Consortium reorganized into independent not-
for-profit corporation, the Eclipse Foundation,
in early 2004

+ Participants from over 100 companies
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Eclipse Foundation & Members

+ Board of Directors and full-time Eclipse
management organization

+ Councils guide the development done by Eclipse
Open Source projects

+ 180 members (March ‘08)
+ 21 strategic members

+ 942 committers, representing 50+ organizations

Strategic Members
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Eclipse Member companies

Eclipse Membership through March 2008
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Parallel Tools Platform (PTP)

+ The Parallel Tools Platform aims to provide a highly
integrated environment specifically designed for parallel
application development

+ Features include:

+ An integrated development environment (IDE) that
supports a wide range of parallel architectures and runtime

systems oo
+ A scalable parallel debugger o
+ Parallel programming tools

(MP1/OpenMP)

+ Support for the integration

of parallel tools
+ An environment that simplifies the

end-user interaction with parallel systems | =~~~ =~

+ http://www.eclipse.org/ptp
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PTP
Software Prerequisites

+ Java (1.5 or later)
+ Cygwin or MinGW (for Windows)

+ make, gcc, and gdb (or other vendor
compilers)

+ OpenMPI or MPICH2 (only required for PTP
Runtime)

Note:
+ Linux & Mac have full PTP support

+ Windows can be used for Eclipse, targeting a
remote parallel machine
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Java Prerequisite

+ Eclipse requires Sun or IBM versions of Java
+ Only need Java runtime environment (JRE)
+ Java 1.5 is the same as JRE 5.0

+ The GNU Java Compiler (GCJ), which comes standard
on Linux, will not work!
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Eclipse and PTP Installation

+ Eclipse is installed in two steps
+ First, the ‘base’ Eclipse is downloaded and installed
+ This provides a number of pre-configured ‘features’

+ Additional functionality is obtained by adding more
‘features’

+ This can be done via an "update site’ that
automatically downloads and installs the features

+ Features can also be downloaded and manually
installed

+ PTP requires the following features
+ C/C++ Development Tools (CDT)
+ Parallel Tools Platform (PTP)
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Eclipse Installation

+ Two alternatives for installation:

+ The Eclipse Classic is the full software development kit
(SDK), including Java and Plug-in development tools

+ The Eclipse IDE for C/C++ developers is the base Eclipse
platform plus the CDT (C/C++ Development tools).
This is ideal for PTP use (included on the tutorial CD)

+ Eclipse is downloaded as a single zip or gzipped tar file
from http://eclipse.org/downloads

+ You must have the correct file for your operating system
and windowing system

+ Unzipping or untarring this file creates a directory
containing the main executable
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Platform Differences

+ Single button mouse (e.g. MacBook)
+ Use Control-click for right mouse / context menu

+ Context-sensitive help key differences
+ Windows: use F1 key
+ Linux: use Shift-F1 keys
+ MacOS X
+ Full keyboard, use Help key

+ MacBooks or aluminum keyboard, create a key binding
for Dynamic Help to any key you want

+ Accessing preferences
+ Windows & Linux: Window » Preferences...
+ MacOS X: Eclipse» Preferences...
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Starting Eclipse

+ Linux
+ From a terminal window, enter

|<eclipse installation>/eclipse/eclipse &

+ MacOS X
+ From finder, open the Applications»eclipse folder
+ Double-click on the Eclipse application

+ Windows
+ Open the eclipse folder
+ Double-click on the eclipse executable

+ Accept default workspace when asked
+ Select workbench icon from welcome page (&
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Specifying A Workspace

+ Eclipse prompts for a workspace location at
startup time

+ The workspace contains all user-defined data

+ Projects and resources such as folders and files
Workspace Launcher B
Select a workspace

Eclipse SDK stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.
The prompt can be
tu rned Off Workspace: | /homejtutnn/workspace M | Browse...

‘I:l Use this as the default and do not ask again
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Eclipse Welcome Page

+ Displayed when Eclipse is run for the first time
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Adding Features

+ New functionality is added to Eclipse using features

+ Features are obtained and installed from an update site
(like a web site)

+ Features can also be installed manually by copying files
to the features and plugins directories in the main
eclipse directory

Module 1 PTP Tutorial 1-18

Installing Eclipse Features
from an Update Site

+ Three types of update sites
+ Remote - download and install from remote server
+ Local - install from local directory
+ Archived - a local site packaged as a zip or jar file
+ Eclipse 3.3.2 comes preconfigured with a link to the
Europa Discovery Site

+ This is a remote site that contains a large number of official
features

+ Europa projects are guaranteed to work with Eclipse 3.3.2
+ Many other sites offer Eclipse features
+ Use at own risk

Module 1 PTP Tutorial 1-19
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Installing from a Local Update Site

We have combined everything needed
for the tutorial onto a local update site
on the CDROM

From the Help menu, choose
Software Updates»Find and
Install...

Select Search for new features to

install

Click Next > /
Click New Local Site...

Navigate to your CDROM, select the

updatesite folder and click Choose
(OK on Linux or Windows)

& Install 8%
Update sites to visit
Select update sites to visit while looking for new features. ,)-—'

Sites to include in search:
[ <] Europa Discovery Site
[ <] The Eclipse Project Updates

‘New Remote Site...
| New LocalSite... |

| New Archived site... |

[ Import sites... |

| Exportsites... |

& Edit Local Site %
W lgnore feat]
= eamllaig: [Tutorial ]

Enter Tutorial for the Name
(or use default: TutorialCD/

URL: ‘ﬁle:/media/cdrom/updatesite/ \

updatesite)
C|ICk OK @ oK [ cancel |
Module 1 PTP Tutorial 1-20

Installing Tutorial Features

+ Make sure only Tutorial

N . & Updates o %

is selected, other options search Results =

as d efa u |tS Select features to install from the search result list. ’)l_
+ CIICk FInISh \ Select the features to install:

+ From Search Results,
select Tutorial (open
the twisty to see the

Deselect All ‘

Contents) Select Required\
1of 1 selected.
| Show the latest version of a feature only
[ Filter features included in other features on the list
® Next > | cancel
Module 1 PTP Tutorial 1-21
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Choose features eoo e =

+ Choose PTP features to
install

+ Easy way to choose:

Select features to install from the search result list.

O

Select the features to install:

1 v < TutorialCD/updatesite ( Deselect All )
[m} » 100 CDT 4.0.3.200802251018
(] » 000 Parallel Tools Platform 2.0 ( Moremfo )

Properties

Select Required

0 0f 23 selected

Select the features to install:

+ Select all

+ Unselect anything
with red “X”

+ This omits features
for which you lack
the pre-requisites

[ 4 Parallel Tools Platform End-User Runtime 2.0.0.200803280847
[ @ PTP Parallel Language Development Tools 2.0.0.200803280847

[ @ PTP Common External Components 2.0.0.200803280847
[ 4 PTP Remote Tools Enabler 2.0.0.200803280847

[ 4 PTP RSE Enabler 2.0.0.200803280847

[ G PTP Remote Tools 2.0.0.200803280847

[ @ PTP Support For IBM LoadLeveler 2.0.0.200803280847

[ @ PTP Support For IBM Parallel Environment 2.0.0.200803280847

[ @ PTP Support For Open MPI 2.0.0.200803280847

[ 4 PTP Scalable Debug Manager 2.0.0.200803280847

[J 4 PTP Support For MPICH2 2.0.0.200803280847

[ G PTP Performance Analysis Framework 1.0.0.200803280847

[ @ PTP Remote Development Tools 1.0.0.200803280847

[ @ PTP Performance Analysis Framework for TAU 1.0.0.200803280847

[ G PTP Performance Analysis Framework: TAU Fortran Enabler 1.0.0.200803280847
(] 4 PTP Parallel Language Development Tools - LAPI support 2.0.0.200803280847
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Finishing Installation

Click Next >

Accept the license terms

Click Next >

Click Finish

For Feature Verification, click
Install All

Restart the Eclipse Platform when
asked

Install/Update

changes to take effect, but it may be possible to apply the
changes to the current configuration without restarting. Would
you like to restart now?

@ It is recommended you restart the Eclipse Platform for the

L Yes \\ [ No | | Apply Changes |

= Updates
Search Results
Select features to install from the search result list.

Select the features to install:

| Deselect Al |

| select Required

@ Next > [ cancel

Module 1 PTP Tutorial 1-23
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File Edit Refactor Navigate Search Project Run Window Help
+ Welcome page | _feomes Lo A
informs you of Q @ <+ & %l I
new features Go to
: _ oto
installed Overview workbench
Select
Workbench icon The Eclipse Platform is a kind of universal tool platform - an open extensible IDE for anything and nothing in particular
tO gO tO = Parallel Tools Platform
workbench ;‘eaair'grry\‘w‘ole about PTP, the Parallel Tools ‘__YZHOW
. indicates new
*" Parallel Language Development Tools : n
Learn more about PLDT, to help in developing featu res ju st
MPI and OpenMP programs, installed
>~ Workbench basics
] Leam about basic Eclipse workbench concepts
o It
Module 1 PTP Tutorial 1-24

(Installing the PTP Proxy)

+ Normally installed on a parallel machine
+ e.g. a cluster
+ Can install on a non-parallel system
+ Not available for Windows
+ Requires OpenMPI to be built and installed
+ This process depends on the type of machine
+ Beyond the scope of this tutorial
+ To install the proxy, do the following steps from a terminal
+ Change to your Eclipse installation directory

+ Change to plugins/org.eclipse.ptp.os.arch 2.0°, where
os is your operating system (macosx Or linux), arch iS your
architecture (ppc, x86, or x86_64)

+ Run the command: sh BUILD
* Directory may include a suffix of build date timestamp.
Module 1 PTP Tutorial 1-25
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Workbench

+ The Workbench represents

[v] Resource - Eclipse SDK ===
the deSktOp development File Edit Navigate Search Project Run Window Help
. riv Qv | |Gy Gle o Gv Dy ;-,‘Resoume
environ ment [ Project Explorer &2 = =8
+ It contains a set of tools 2 &
for resource management
+ It provides a common Pl B Coroe] @ % 3 ¥ =0
way of navigating through — — “’ml [oescmion
the resources e s ot vt
+ Multiple workbenches can
be opened at the same
time — K 772 ]
Module 1 PTP Tutorial 1-26

Workbench Components

+ A Workbench contains perspectives

+ A Perspective contai

ns views and editors

Resource - MyCproject/src/MyCproject.c - Eclipse SDK
Edit Refactor Navigate Search Project Run Window Help
perSpeCtIVG [2 Project Explorer &3 = 0 | [g MyCproject.c % =8
Lo
S #include <stdio.h> ]
< & MyCproject #include <stdlib.h>
. s
EdItOI’ = int main(void) {
b i Includes puts("!!!Hello World!!!"); prints 111
/VJK return EXIT_SUCCESS;
b e } =
K 72 |
b (=Debug L]
ZITasks 8 E Console 3% »Y°=0
5Z Outline 5 el
VleWS B R o Y ‘/ |! |Des:nvnon |Resoume |F
\ = stdioh
T
© main(void) : int [
-
Module 1 PTP Tutorial 1-27
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Perspectives

+ Perspectives define the layout of views in the
Workbench

+ They are task oriented, i.e. they contain
specific views for doing certain tasks:

+ There is a Resource Perspective for manipulating
resources

+ C/C++ Perspective for manipulating compiled code
+ Debug Perspective for debugging applications

+ You can easily switch between perspectives

Module 1 PTP Tutorial 1-28

Switching Perspectives

+ You can switch
Perspectives by:

+ Choosing the
Window»Open
Perspective menu
option

+ Clicking on the -~
Open Perspective

return EXIT_SUCCESS;
} |
K3 —7A— Bl

I Tasks 8 E Console X 3 v =8

0 items

button AR o 7|[v [ [oescipion [Resoure [F
+ Clicking on a i

perspective shortcut| ° o o o

button o

Module 1 PTP Tutorial 1-29




Available Perspectives

. Window »
+ By default, certain Open Perspective

perspectives are available
in the Workbench

[= Open Perspective

+ We,” use: CVS Repository Exploring
%5 Debug
+ C/C+ + %% PTP Debug
+ PTP Runtime % PTP Runtime
[25 Resource
+ PTP DebuQ £9 Team Synchronizing
[ ok || cancel |
Module 1 PTP Tutorial 1-30

+ The workbench window is T o e——
divided up into Views — e
+ The main purpose of a view is:
+ To provide alternative ways of presenting information
+ For navigation
+ For editing and modifying information

+ Views can have their own menus and tqQolbars

+ Items available in menus and toolbars are
available only in that view

+ Menu actions only
. Oz i 3 s g v =
apply to the view o= Outline 32 B RW e o

4+ Views can be resized e main() : int

Module 1 PTP Tutorial 1-31
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Stacked Views

+ Stacked views appear as tabs
+ Selecting a tab brings that view to the

foreground

£ Project Explo®

¥ =5 MyCproject
b 3 Binaries
b ) Includes

Resource - MyCproject/src/MyCproject.c - Eclipse SDK

Sl ¥ Ge e [ |.JResource Iud

[&) MyCproject.c 2 =0

#include <stdio.h>
#include <stdlib.h>

int main(void) {
puts("!!!Hello World!!!"); prints H\|:|

< Bsrc return EXIT_SUCCESS;
> g
b (=Debug 8]
7 Tasks & Bl Console ] X Y =0
5% Outline 52 = B items
% N o Y[ i [pescription [Resource [F
= stdioh
= stdiib.h
© main(void) : int al
o @
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Access help

+ Help»Help Contents

+ Help»Search

+ Help»Dynamic Help
Help Contents provides
detailed help on different
Eclipse features
Search allows you to
search for help locally, or
using Google or the Eclipse
web site
Dynamic Help shows help
related to the current

Contents ¢ 0

> Workbench User Guide

> Java Development User Guide
> Platform Plug-in Developer Guid
%> JDT Plug-in Developer Guide
> Plug-in Development Environme
&> PTP: Parallel Tools Platform

‘> PTP Parallel Language Developr
> CDT Plug-in Developer Guide
> C/C++ Development User Guide

[ 37 co—

Using the Eclipse help system

Browse topics in the Contents frame (E)yon
the left. Click on a topic to have it displayed.
Use the Back and Forward buttons to
navigate within the history of viewed topics.

Searching

To quickly locate topics on a particular
subject in the documentation, enter a query in
the Search field. Use the Search frame (') to
display the Search view. You can narrow the
scope of your search by selecting only the

ConteXt (perspeCtiVe, VieW, EF Lw,z] ‘secuons you are interested in. n
etc.) =
Module 1 PTP Tutorial 1-33
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Open PTP Runtime Perspective

Window > Open Perspective > Other...

| Window LT3
New Window
[ Oen perspective > [T .
Show View \> £Y Team Synchronizing e "
[&hg CVS Repository Exploring
Customize Perspective... Other... %5 Debug
Save Perspective As... \ # PTP Debug

Reset Perspective
Close Perspective
Close All Perspectives

858 PTP Runtim
|5 Resource
£Y Team Synchronizing

Navigation >
Working Sets > OK Cancel
Preferences...

Module 1 PTP Tutorial 1-34

Terminology

+ The PTP Runtime perspective is provided for
monitoring and controlling applications
+ Some terminology

+ Resource manager - Corresponds to an instance of
a resource management system (e.g. a job
scheduler). You can have multiple resource mangers
connected to different machines.

+ Queue - A queue of pending jobs

+ Job - A parallel application

+ Machine - A parallel computer system

+ Node - Some form of computational resource

+ Process - An execution unit (may be multiple
threads of execution)

Module 1 PTP Tutorial 1-35
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PTP Runtime Perspective

£ PTP Runtime - mpitest/mpitest.c - Eclipse SDK. 28
Hle Edt Refactor Navigate Search Project Run Window Help

Resource e o e
Managers view=— s =

Machines view —>

Node details
view

erties| & Tasks @) Emor Log

ssplay 2t this time.

Jobs view =™

Module 1 PTP Tutorial 1-36

Resource Managers

+ PTP uses the term resource manager to refer to any
subsystem that controls the resources required for
launching a parallel job.

+ Examples:
+ Job scheduler (e.g. LoadLeveler)
+ Open MPI Runtime Environment (ORTE)

+ Each resource manager controls one target system
+ Resource Managers can be local or remote

Module 1 PTP Tutorial 1-37
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File Edit Refactor Navigate Search Project Run
7 o | B O~ Qv

(2 Resource Managers &2

Window Help

+ Right-click in Resource
Managers view and select
Add Resource Manager

£ Machines %3

+ Choose the ORTE =

=
ReSOU rce Manager Choose Resource Manager Type
Type

X

Select the type of resource manager to use

Resource Manager Types:
LSF

+ Select Next> s

A
ORTE

Module 1 PTP Tutorial 1-38

Configure the

(=

ORTE Proxy Configuration

+ Can choose Remote

___ service provider

+ Can choose Proxy
server location

Enter information to connect to an ORTE proxy server

Remote service provider: | Local

Proxy server location: | Local

Path to proxy executable: (847/bin/ptp_orte_proxy| [ Browse “ Options... \

Multiplexing Options

(= x|
@ None Choose Resource Manager Name and Description
Local address for proxy connection: |localhost localdomain v Enter a name and description for the resource manager
i
[[] Use default name and description:
[ Launch server manuall ORTED Configuration
Y Enter information to configure ORTED Name: [ORTE@ Local ‘
Description: [ORTE Resource Manager \
W] Use default settings
® Nex{ Path to ORTED:
Extra ORTED arguments:
. @ Finish | cancel
For details on remote . = )
resource managers, see
Module 5 @ [ <pack |[ Nexts |[ Enish || cancel |
Module 1 PTP Tutorial 1-39
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Starting the Resource Manager

+ Right click on new
resource manager and
select Start resource
manager

+ If everything is ok, you
should see the resource
manager change to green

+ If something goes wrong,
it will change to red

(. Resoffrce Managers &2

@ ORTE@N.N.N.N (ORTE)

Module 1

\

(+) Resource Managers £

@ ORTE@N.N.N.NgL22

Add Resource Manager...
Remove Resource Manager

\ Edit Resource Manager
232 Machines 2

H P Start Resource Manager
Please select a mac

\¢ Resource Managers £
b (3 ORTE@N.N.N.N (ORTE)

PTP Tutorial 1-40

System Monitoring

+ Machine status shown in
Machines view

+ Node status also shown
Machines view

+ Hover over node to see
node name

+ Double-click on node to __
show attributes

Module 1

(%) Resource Managers 2 =0

» &) ORTE@N.N.N.N (ORTE)

&8 Machines &3 & o~ e =08
~ORTE@N.N.N.N: localhost.localdomain - Root [64]

EE localhost localdomain 0
0

Attribute Value

Node Number 0
Node State upP
| TR [>]
PTP Tutorial

(<

20
30
40
50
60
Node Attributes Process Info

R o o )
[ o o
[ o o o
[ ) o o o
[ ) o o
[ ) o o

[ES S En g Eu)

1-41
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Module 2: Creating and
Running MPI Programs

+ Objective
+ Learn how to use Eclipse to develop parallel programs
+ Learn how to run and monitor a parallel program
+ Contents
+ Brief introduction to the C/C++ Development Tools
+ Create a simple application

+ Learn to launch a parallel job and view it via the PTP
Runtime Perspective

Module 2 PTP Tutorial 2-0

Switch to C/C++ Perspective

) Help
‘.’ Only needed |f New Window s
you're not
H CVS Repository Exploring
a I ready I_n the Show View > [y Resource
perspective . :
Customize Perspective... Other...

Save Perspective As...
Reset Perspective
Close Perspective
Close All Perspectives

Open Perspective

{23 CVS Repository Exploring

Navigation >
= %5 Debug
~ Working Sets > # PTP Debug
Preferences... 888 PTP Runtime
[t Resource

£0 Team Synchronizing

oK ‘ Cancel ‘

Module 2 PTP Tutorial 2-1




Project Explorer View

+ Represents user’s data
+ It is a set of user defined

resources ' Project Explorer &3 =08
+ Files =2 5 7
+ F0|der'S b+ Binaries
+ PrOJeCtS P[5 Includes
v Esrc
+ Collections of files and

P Lel MyCproject.c
folders b (=Debug

+ Plus meta-data

+ Resources are visible in
the Project Explorer View

Module 2 PTP Tutorial 2-2

Editors

+ An editor for a resource (e.g. a file)
opens when you double-click on
a resource 2

+ The type of editor depends on the type of the resource
+ .c files are opened with the C/C++ editor
+ Some editors do not just edit text
+ When an editor opens on a resource, it stays open across
different perspectives
+ An active editor contains menus and toolbars specific to that
editor
+ When you change a resource, an asterisk on the editor’s title
bar indicates unsavedyénges

Lc| *MyCproject.c &3

Module 2 PTP Tutorial 2-3




Source Code Editors

A source code editor is @ & linear_function.c 5 =0
special type of editor for | V7' . C
manIPUIatlng source double evaluate(double x)
COde v add semicolon to end of xt i
doubl = 3.0% + 2.0

Language features are o rewmy g
highlighted :
Marker bars for showing

+ Breakpoints

+ Errors/warnings
+ Tasks
Location bar for
navigating to interesting
features

Module 2 PTP Tutorial 2-4

Set up for MPI development
Preferences

+ To use the PTP Parallel Language Development Tools feature for
MPI development, you need to

+ Specify the MPI include path r f D
+ Specify the MPI build command b Genera MP1include paths:
+ Open EE/LH fusitocalinclude
Window » Preferences... o e
+ Open the PTP item e
+ Open the Parallel Language | “77 " weisuidconmand e
Development Tools item
+ Select MPT — | ..
+ Select New... to add MPI b Runoens
include path b Team ooy
+ If running OpenMP, add its

include file location here too
(we will cover that later)

Module 2 PTP Tutorial 2-5




Creating a Parallel Application

Steps:

+ Create a new C project
+ Edit source code

+ Save and build

Module 2 PTP Tutorial 2-6

Creating a simple
MPI Project (1)

Create a new MPI project

+ File»New»C Project Create  prect ofselected type =
4+ Name the p rOj ect:”//d’mn name: [MyHeloproject|

N MyHel |0Pr0JeCt’ ¥ Use default location
+ Under Project types, under

Executable, select MPI e e -
Hello World C Project \ < e

and hlt NeXt © MPIPi C Project
+ On Basic Settings page, < g et
fill in information for your < v e v

new project (Author
name etc.) and hit Next

Module 2 PTP Tutorial 2-7




Creating a simple
MPI Project (2)

2 [x]
+ On the MPI Project Settings ,,,,,mjmmgs _k,L
wizard page, ma ke sure Add Select the MP! include path, lib name, library search path, and build
MPI prOjeCt settings tO thiS command information to be automatically be added to the new project.
project is checked. "— :ddrilije:'m?g s
+ Change default paths, etc. if =" /. sefocalincce
necessary (they are probably Library name mp
OK) Library h path ustflocalflib
+ Hit Finish*, HPH"‘i COVW:JM r“'mf
+ *If you instead hit Next, then - -
on the Select Configurations
page, you can alter Project
Settlngs. Hlt Fil‘liSh. @ < Back Next > H Einish H Cancel
Module 2 PTP Tutorial 2-8
Changing the C/C++ Build
Settings Manually
+ Open the project properties

+

by right-mouse clicking on

-
- [[type fiter text] Settings.
project and select
Configurati Debug < || Manage configurations
- Builders
Properties -
. / Discovery options [ §Tool settings | # Buid steps | Buid artifact | Binary parsers | @ Error parsers | |
Open C/C++ Build —— )
-~ All options: -ljusiflocalfinclude -00 -g3 - |

Wall -c -fmessage-
length=0

Select Settings —
Select GCC C Compiler to — fetctonn s
change compiler settings s
Select GCC C Linker to—— ‘o
change linker settings :

It’s also possible to change ‘ )
compiler/linker arguments . o e

Expert settings:
Command
line pattem: ${COMMAND} ${FLAGS} ${

Module 2 PTP Tutorial 2-9




Editor and Outline View

MyWo

File Edit Refactor Navigate Search Project Run Window Help

+ Double-click on

) X v L @ & | @ &y @ o |& B | O @ @~ | O & |Ec/c+)
source file in the & 7@ e e
= 5 Project Explorer 2 = B [¢] MyHelloProject.c &3 =0|%out 8 @ Mak =8
Pro.]ect Explorer \ = % Y| #include <stdio.h> [ B R W M
to open C editor < & MyHeloProject e orringh> u stdoh
b 4 Binaries int main(int argc, char* argv[]){ L J Sm‘ng‘h
R, & Includes int my_rank; /+ rank of process * o mpih
) ) ) E int p; o mainint, chart(]) : in
+ Outline view is B MyrieloProject.c int source;

b = Debug

shown for file in
editor —_—

char message[16€0];
MPI_Status status ;

T

[20 Problems 52 Vi Tasks El Console

Properties & Remote Environm = 8

0 errors, 0 warnings, 0 infos n v
Description Resource Path Location
Writable sm..rt NEEKR
Module 2 PTP Tutorial 2-10

Content Assist

+ Type an incomplete MPI function name e.g. "MPI_Ini" into the
editor, and hit ctrl-space

+ Select desired completion value with cursor or mouse

MPI_ Inij
© MPL_Init(int *, char ***) int
* find o MpI_nit_thread(int =, char ***, int, int %) int
MPI_Com o MpI_Initialized(int =) int

+ Hover over the MPI Artifact

find out process rank *

identified in the source file to MPT Colm_yank (MPI_COMM WORLD, &my_rank);

see additional information Brotatype: it T Conm_rark(VP1_Conm,

a b ou t t h a t fU n Ctl on Ca | I 7 fO r RD:hs.lfrzlsp;':':.;nk of the local task in the group assodiated with a communicator.,
Press 'F2’ for focus

example

Module 2 PTP Tutorial 2-11




Context Sensitive Help

+ Click mouse, then press help
key when the cursor is within a
function name

+ Windows: F1 key b the rank of thelocal tak it the croup assodated with 3 com

+ Linux: ctrl-F1 key -

@ Help 2 & ¥ =0
+ MacOS X: Help key or e =
Help»Dynamic Help Re:ted Topics
. ¥ About
+ A help view appears (Related | ..o toseenen.
Topics) which shows See alor .
additional information S e S e
+ Click on the function nameto ==
see more information DRl ; =
. . d @ el ¢
+ Move the help view within your .
Eclipse workbench, if you like, MPI_Comm_rank
by dragging its title tab e 3 o a5 o, )
Retums the rank of the local
task in the group associated
with a communicator.
Module 2 PTP Tutorial 2-12

Running a Parallel Application

Steps:
+ Create a launch configuration
+ Run the application

+ Monitor its progress in the PTP Runtime
Perspective

Module 2 PTP Tutorial 2-13




Organize Favorites...

+ Open the run
configuration
dialog Run»
Open Run Dialog...
+ Select Parallel
Application
+ Select the New
button

Module 2

a Launch Configuration

=R R
Create, manage, and run configurations P 8
Create a configuration to launch a parallel application in Parallel Perspective KQJ

= 3 Configure launch settings from this dialog:
D | - Press the 'New' button to create a configuration of the selected type.

] C/C++ Local Application - - Press the 'Duplicate’ button to copy the selected configuration.

i Parallel Application ¥ - Press the 'Delete’ button to remove the selected configuration.

3 - Press the *Filter' button to configure filtering options.

- Edit or view an existing configuration by selecting it.

Configure launch perspective settings from the Perspectives preference
page.

Filter matched 2 of 2 items

Close |

®

PTP Tutorial 2-14

Complete the Resources Tab

= Run

+ In Resources tab, select Create, manage, and run configurations
the resource ma nager yo u Create a configuration to launch a parallel application in Parallel Perspective
want to use to launch this S % & %

job
+ Enter a value in the

Name: | MyHelloProject
|type filter text |

Application | %5 Debugger - Arguments| %, Source 7§ Environment | ™q

[€]C/C++ Local Application [oRTE@Local =

< & Parallel Application

Number of Processes:

Number of Processes field WHICGREESIRR | et s @

Module 2

D)

Apply || Revert
Filter matched 3 of 3 items
2 Run Close

PTP Tutorial 2-15




+ Ensure that the correct
Parallel Project is selected
+ Select the Application
program (executable) by
clicking the Browse button
+ Local program: executable
is under Debug folder in the
project
+ Remote program: must
copy to remote machine;
navigate to its location on
the remote machine here.
Select Display
combined output in a
console view if desired

Module 2

Complete the Application Tab

Create, manage, and run configurations
@ [Debuggerl: No debugger avalable

) Name: [MyHelloProject
[type filter text

(€] C/C++ Local Application
= &4 Parallel Application

i myHelloProject

£ Resourceg’") Application Y Debugger | ¢ Arguments | & Source 7§ Environment
Parallel Projet

18D
Filter matched 3 of 3 items

PTP Tutorial

Browse
Application program:
y t Browse
1 Display combined output in a console view
Apply Reyert
Close

Complete the Debugger Tab

+ Select Debugger tab

+ Choose SDM from the
Debugger dropdown

+ Confirm the debugger

L
Create, manage, and run configurations
Create a configuration to launch a parallel application in Parallel Perspective

x| 8 3 Name: [MyHelloproject

type filter text |

[2 C/C++ Local Application ‘
Debugger: [SDM

£ Resources | ) Applicatio{ %> Debugger’) ®- Arguments | %, Source 7§ Environment

executable E—
+ Set debugger session e
address [cinstalrest; lipse.ptp linux.x86_2.0.0. | [ Browse
Debugger session address:
+ In Arguments tab, enter [localhost localdomain
arguments and working
directory
+ Click on Run to launch the i
program e 3) Apply || Revert
—> Run Close.
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+ Double-click a
node in machines
view to see which
processes ran on
the node

+ Hover over a
process for tooltip
popup

shown in jobs
view

Module 2

+ Job and processes —— EEmm v < Ml @5lse o

He EGt Refactor Navigate Search Project Run Window Help

0-2- Q- |0 = = = [Zemp Aunti] Zocs
=B

char* argv[1){ =

o @ =B

WI_Init(Sargc, Sargv)

WPI_Comn_rank(MPI_COMM WORLD, Say_rank);

WPI_Comn_size(MPI_COMM WORLD, £0)

Node Attributes cess info
Artrbute  Value + o020
Name  noded

Node Numi 0

L2 "5 Sconsole 1 . Problems = Properties 2 Tasks ==
ATE@Local: def 02 - Root [4]

7 Invokis (C € Linker
mpicc local/lib -o"MyelloProject” ./src/

0P lepi
inished building target: MykelloProject

PTP Tutorial 2-18

+ Double-click a
process to see
process detail and
standard output
from the process

Module 2

3 Resource Managers &2 =0 & myreloProjectc | E8job02:0 53 =n

b @ ORTE@Local (ORTE) Process details

PID: 23513
Status: EXTED

~ Program output

& o o P
ORTE@Local: localhost Jocaidomain - Root [10]
= localost localdomain 5

¥ielo MP1 Wiorkd From process 0: um processes: 4
#elo MP1 Weorid from process 1
[1| Heto MP1 wer from process

#elo MP1 Werd from process 3:

Node Attributes
Attribute  Value

Name  nodel
Node Numi 1

haidll = B Console I (2. Problems = Properties| £ Tasks =D
_ C-Buid [MyHeloProject] = S
2 EXTED  PID:23513

PTP Tutorial 2-19
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+ Open using legend icon
toolbar

Module 2

About PTP Icons

in
Resource Manager Icons
@ STARTING
- N @ STARTED
PTP Runtime - jo,"02:0 - Eclip @ STOPPING
% STOPPED
.~ SUSPENDED
@ ERROR
Machine Icons Node Icons
up P & USER SHARED
& DOWN [ pown © OTHER EXCLUSIVE
ALERT E ERROR @ OTHER SHARED
B ERROR 2 UNKNOWN @/ PROCESS RUNNING
2 UNKNOWN @ USER EXCLUSIVE |4 PROCESS TERMINATED
Job Icons Process Icons
© PENDING + STARTING
© STARTED + RUNNING
© RUNNING ¥ EXITED NORMALLY
© TERMINATED = ¥ EXITED WITH SIGNAL
@ SUSPENDED » SUSPENDED
© ERROR ¥ ERROR
@ UNKNOWN % UNKNOWN
PTP Tutorial 2-20
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Module 3: PTP and Parallel
Language Development Tools

+ Objective
+ Learn to develop a parallel program
+ Learn to analyse with PLDT

+ Contents

+ Learn to use PTP’s Parallel Language Development
Tools

+ Learn to find MPI & OpenMP artifacts
+ Learn how to do MPI and OpenMP Specific analysis

Module 3 PTP Tutorial 3-0

Parallel Language Development
Tools (1)

+ Features

+ Analysis of C and C++ code to determine the location
of MPI and OpenMP Artifacts (Fortran planned)

+ "Artifact View" indicates locations of Artifacts found in
source code

+ Navigation to source code location of artifacts
+ Content assist via ctrl+space ("completion”)
+ Hover help

+ Reference information about the MPI and OpenMP calls
via Dynamic Help

Module 3 PTP Tutorial 3-1




Parallel Language Development
Tools (2)

+ More PLDT features:

+ New project wizard automatically configures
managed build projects for MPI & OpenMP

+ OpenMP problems view of common errors

+ OpenMP “show #pragma region” action

+ OpenMP “show concurrency” action

+ MPI Barrier analysis - detects potential deadlocks

Module 3 PTP Tutorial 3-2

Show MPI Artifacts o

Select source file; Run B> show NPT Actfacts
analysis by clicking on =
drop-down menu next

to the analysis button
and selecting Show
MPI Artifacts e
Markers indicate the 5
location of artifacts_in
editor Bue

In MPI Artifact View | o~}
sort by any column 1
(click on col. heading)™~

Navigate to source code \‘ E o Ejém
||ne by dOUb|e-C|ICkIng | Tasks | B Console (£ Problems | > MPI Artifact View £ i X%

| Tarifact | Fitename | LineNo [constnet |

C/Ct+ - MyMPIproject/src/MyMPIpre ect.c - Eclipse SDK

< &5 MyMPlproject

char
MPI_Status

tart up MPI =

on the artifact : MPI_Bcast MyMPlproject.c 2 Function Call
. MPI_Reduce MyMPlproject.c 7 Function Call

Ru n the ana |ys|s on : MPLinit MyMPlproject.c 57 Function Call

another file and its > upLconn-sze s

markers will be added to & s s

the V|eW ) » MP\:Fmahzg MyMPlproject.c 94

Remove ma rke rs V|a X 0 Wiitable SmartInsert | 60: 18
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MPI Barrier Analysis

S0/ - Eclipse SDK - C: 440 BEX]
Fie Edt Refoctor Source Statstcs Navigate Search Project Run Vindow Fep
F-0-Q- IS O- @it
(5 Resource
= O)[ 52 outine 52\ © Make Targets| = O
GL BRW o T

i ]
Matches 22

=l

= 01| (v Barrier LT
i Barrier Matching Set Function
retto |a)|| = P Eor main
1 Path 1.
Whpath 2
/i Error mai
1) Loop (ynamic number of barrers)
3) [ >
SELEE

Module 3

PTP Tutorial

Verify barrier
synchronization in C/
MPI programs
Interprocedural static
analysis outputs:

+For verified programs,
lists barrier statements
that synchronize
together (match)

+ For synchronization
errors, reports counter
example that illustrates
and explains the error.

MPI Barrier Analysis - views

/13 MP1 Barriers &3

Function Barrier Matching Set

v man & Ui Barrier 1(2)
YA mein 1) Barrier 1
¥4 main 1) Barrier 3
Y4 main ¥4 Barrier 2 (1)
YA mein 1) Barrier 2
h  Barrier -4 Barrier 3 (2)
1) Barrier 1

1) Barrier 3

1) Barrier 4 (0)

¥4 Barrier 5 (1)

< B |(E3f

= O ||[2. Problems | 2| Tasks | £l Console |/ Barrier Matches 2

= 0|4 Barrier Erors 2 i v=8
i 7 || Barrier Matching Set Function
Function Filename LineNo _[»](| %4 i =3
Barrier MyBarrier.c s L RIS )
1) Path 2 (0 barrier(s))
Barrier MyBarrier.c 8
main MyBarrier.c 41 O e L
5 el -1/ Loop (dynamic number of barriers)
main MyBarrier.c 31
main MyBarrier.c 31
main MyBarrier.c 41
Barrier MyBarrier.c 8
main MyBarrier.c 41
main MyBarrier.c 57
main MyBarrier.c 62 o
> <l >
YEE

MPI Barriers view
Simply lists the barriers

Like MPI Artifacts view,
double-click to
navigate to source
code line (all 3 views)

Module 3

Barrier Matches view
Groups barriers that
match together in a
barrier set - all
processes must go
through a barrier in
the set to prevent a
deadlock

PTP Tutorial

Barrier Errors view

If there are errors, a
counter-example
shows paths with
mismatched number
of barriers
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OpenMP Managed Build Project

+ If you haven't set up = p—

O pe n M P p refe rences e. g . Create C project of selected type
include file location, do it }K MyOpenMPproject
Use default location

now
+ Create a new OpenMP S Tesenan

project

© Hello World C++ Project

+ File»New»C Project :::va;:feiNsw C Project
+ Name the project e.g! © MPI Hello World C Project

‘MyOpenMPproject’ //: Ot e ot P
+ Select OpenMP Hello World C et e € Proet
+ Select Next, then fill in other ~ 4] Show project types and tooichains orly i they are supported on th plaform

info like MPI project \

@ [ <Back | News |[ Emsh |[ cancel

Module 3 PTP Tutorial 3-6

Setting OpenMP' Special
Build Options

) ) <= Properties for MyOpenMPproject @
+ OpenMP typically requires [ settings
special compiler options. s T <l |

+ Open the project ol
prop ertl es :::’:g;n wditor i Tool settings | 4 Buid steps Build artifact | ot Binary parsers | @
/U cii”;:‘:zml 5 % GCC Assembler | Other flags | - -fmessage-tength=
H G [Cverbose (+)
+ Select C/C++ Build o e e
- Run/Debug Settings
+ Select Settings
+ Select C Compiler

+In Miscellaneous,
add option(s).

Preprocessor

(5 shared Librery Se =
< >

Module 3 PTP Tutorial 3-7




Show OpenMP Artifacts

2 C/C++ - MyOpenMPproject/src/MyOpenMPproject.c - Eclipse SDK - C:\ews\runtime-temp |=%]
Fle Edt Refactor Navigate Search Project Run Window Help
= SRC ARG ARC A 2 H-O0- Q- O~ [ 5 Debug [ c/c++ & Iava
. >S5 m 0 G-
+ Select source file, | tromeme i =56 momemom =B % =5
. < domble *x, -~ AR o ¥
folder, or project = 8 g "0 o
®- @) Indudes o stringh
H B3 src o stdibh
+ Run analysis Ny e » U
B 25 myopentproject o opemoh
®- @)l Incudes . B N . ©  main(int, char
OB s x = (double *) malloo( ( : * sizeof (dot
& éoﬂghgomwwmm v = (double *) malloc( ( * sizeof (dov
3} N - | N
W Show MPI Artifacts B 8= 5
W Show OpenMP Artifacts < YI4] = sin( exp( cos( - exp( sin(x(i]) ) ) ) ): =
/4, MPI Barrier Analysis :eturn 0:
4 v
<] i ] > (2 - >
H H e Probieme e L consalin g £ CpcrifP Artact View =0
+ See artifacts in T
H VP Artifa ilen: in
OpenMP Artifact i A e &
View W =pragma omp paralel for MyOpenMPproject.c 34 Opi
Rk
< I 2]
Module 3 PTP Tutorial 3-8

Show Pragma Region

+ Run OpenMP

ana|y5|s ’ #pr;g'ma omp parallel for u
+ nght C||Ck On fo:'(1=0;1<array51ze; i++ ) ::I
pragma |n vii] = sin( exp( cos( - exp( sin(x[1]) ) ) ) )’
¥
artifact view , T
v
[l w | [> <

[21 Problems | | Tasks | E] Console Debug | @ OpenMP Problems | #9 OpenMP Artifact View £3

+ Select Show

OpenMP Artifact Filename LineNo
pragma region omp_in_paralel MyOpenMPproject.c %
% #pragma omp parallel for TR et =

Show pragma region

+ See highlighted region in C editor

Module 3 PTP Tutorial 3-9




Show OpenMP Problems

SC/Ces - proj penMPp: - Eclipse SDK - C:\ews\runtime-temp |=%]
Fle Edit Refactor Navigate Search Project Run Window Help
C Gl g &8 - iR "B iB-0-Q 0 & %5 Debug
S I o ® 5 L= R RS C R [ cic++ |8 ava
+ elect pen MP (25 Project Explorer 52 = O |([&] "MypenPproject.c | L] openiPproblems.c £3 =08
problems view 5% 7 |y fpeaqm_own,pazallsl for S —— ~
= 5 MyMPIproject for(3=1; 3<10; 3++) {
ITH . ® ) Indudes 344z
+ Will identify standar ® 9 o )
. . (= Debug ¥
OpenMP restrictions @ B et g , i
& @) In void barriercheckd ()
=8 src { -
@ [£] MyOpeniP, 3 int i, 3;
- [c] openMPproblems.c
(> Debug » #pragma_omp
B
» RErE, b n =
)
v
[2. Problems | % Tasks | E Console | @ OpenMP Problems 2 ¥ OpenMP ArtifactView | — O

<]

i~
Description Re
@ For directive embedded within another paralel for or parallel sections opr
® Barrier directive not permitted in region extent of for, ordered, sections, single, master, and critical  op

2)((<]

Writable SmartInsert | 26:5

Module 3

PTP Tutorial

Show

Highlight a statement

Select the context menu
on the highlighted
statement, and click
Show concurrency
Other statements will be
highlighted in yellow

The yellow highlighted
statements might execute
concurrently to the
selected statement

Module 3

Concurrency

int simple(Q{
#pragma omp parallel

int simple2(){
#pragma omp parallel
{

a=1;
b=2;
#pragma_omp barrier
b=3;
a=4;

3-11
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Module 4: Parallel Debugging

+ Objective

+ Learn the basics of debugging parallel programs with
PTP

+ Contents
+ Launching a parallel debug session
+ The PTP Debug Perspective
+ Controlling sets of processes
+ Controlling individual processes
+ Parallel Breakpoints
+ Terminating processes

Module 4 PTP Tutorial 4-0

Launching A Debug Session

Use the drop-down next to

the debug button (bug . file Edit Refactor Navigate Search Run Project Window Help
icon) instead of run button £3 =N Py O Qv | O~ | | 4 o~
Select the project to launch | @ Resource Manage_ =a||
The debug launch will use pebughe

%5 Open Debug Dialog...
the same number Of Organize Fayorites...
processes that the normal

launch used (edit the £ Machines % QAo &P 7
Debug Launch ORTE@sc07tutorial: localhost.localdomain - Root [64] -
- . EE localhost.localdomain O 165 5] ey e I I
Configuration to change) 10 [ [ o o ) o o
20 [0 [0 [ o o o
30 [0 [0 [ o o o oy
Hv Ov Qv | O | & .
50 (00 [0 [ [ ) o o
(LA MymPiProject | sollilil
H Debug As > Node Attributes Process Info
%+ Open Debug Dialog... Attribute  Value !

Organize Fayorites...
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The PTP Debug Perspective (1)

€ PTP Debug - MymP BEE
Fle Edit Refactor Navigate Search Run Project Window Help
+ P-a rallel Debug rev ® % 0ra o | |4 v =[PP Debug| 5 PTP Runti... EC/CH++
view shows JOb 28 Parallel Debug 53 = 0|9 Breakpoints (2= Variables & 47 Expressions| = O
and processes ORTE@scO7tutorial: d I e — >
being debugged I YRS o Name Value
@ my_rank 995765
= o ¢ numprocs 134515657
H LT - b & . 4 source -1076822980
+ Debug view ShOWS ~ £ MyMPIProject [Parallel Application] & dest -1076823128 5
threads and call =" -seuceso ‘ —
- T < 4 Thread [1] (Suspended) a
stack for individual
processes L D
L& testMPlLc 52 job05:0 =8 g outline 2 =8
. A &R e T
H t k; /* rank of pro 2
+ Source view i MEprots; /v humber of . 5 moin
int source; * rank of send / .
shows a current » dest PR TR u stdoh
- int tag = 0; * tag for messages ¥/ o stringh
line marker for all char pessagelico]; /1 storace  cae_piine.int) - voi
MPI_Status status ; * return s [ - §
processes P o maiint, chart) -t
MPI_Init(&argc, &argv);
/% find out process rank
MPI_Comm_rank(MPI_COMM_WORLD, &my_rank); ™
a T
B Console ® 0 Memory @) Eror Log [2 Problems w b = Bvriv=0
- a Q9 «
Module 4 PTP Tutorial 4-2

The PTP Debug Perspective (2)

£ PTP Debug - MyMPIProjs tM) Eclipse SDK = 8 %
Flle Edit Refactor Navigate Search Run Project Window Help

riv @ | v O Qv |O~ |E | 4 B £ | PTP Debug

5 Parallel Debug 3 smmiiallp- °o Breakpoints = Variables &2 . & Expressions| = O

P Runti... EEC/C++

+ Breakpoints view = e A o = =
shows breakpoints | e oy Name value
& my_rank 4545765
that have been set — + s
. Debugles P % source -1076822980
(more on this later)
S0

< £ MyMPIProject [y  dest 1076823128 £
+ Variables view — ~  Thread (1] (Suspended) l:

shows the current
I Dl
5:0

values of variabley  testiple 12 B jobo =0 & outine = -
¢ 6 AR o "
int k; * rank of L
for the currently e mme e T
H int /* rank of .
selected process in | cimdes o v ot @ stdon
int tag = 0; o stringh
the Debug view char s MEESEIC0): e i calc_plt, ) vod
- ’ , ch: i
+ Outline view (from | ===~ it ot o
CDT) f MPI_Init(&argc, &argv);
of source R
Code MPI_Comm_rank (MPI_COMM_WORLD, &my_rank); [~ v
= [
& Console 3 0 Memory €] Error Log (2. Problems. % BB
e alp = ¢
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Stepping All Processes

The buttons in the
Parallel Debug View
control groups of
processes

Click on the Step Over
button

Observe that all process
icons change to green,
then back to yellow
Notice that the current
line marker has moved to
the next source line

Module 4

_w_a_, o> 3 ® 0 K o~ @y =8
ORTE@sc07tutorial: default:job06 - Seet 4]
£ job02 o> »+» [j
%> Debug R [ir 3 v =8
< §% MyMPIProject [Parallel Application]
~ & Process 0
v # Thread [1] (Suspended)
= 1 main() testMPI.c:50 80489b0
(& testMPl.c %2 & job05:0 =F
g 5]
| + start up MPI *
\ MPI_Init(&argc, &argv);
o + find out process rank *
» MPI_Comm_rank (MPT_COMM_WORLD, &my_rank);
| + find out number of processes *
MPI_Comm_size (MPI_COMM_WORLD, &num_procs);
©
PTP Tutorial 4-4

+ The buttons in the
Debug view are used
to control an
individual process, in
this case process 0
Click the Step Over

button

You will now see two
current line markers,

the first shows the
position of process 0,

the second shows the
positions of process9/
1-3

Module 4

Fle Edit Refactor Navigate Search Project Run Window Help
(wind & W iy Oy (< v Qv | O | 5 v §iv <14 E
£ Parallel Debug 3 =0 %Br¢fE w-v % gBsi gBar/@pP | =0
ORTE@Local: default:job02 - Root [4] % B -
[~ & v &)
i3 B ® 0 =K 1Y @ s e
£ job02 o+ + -+ }» o my_rank 0
% num_procs 134515657
%5 Debug &2 =8 P
% source -1081228708
I3 —p e A dooe a <
> B —— D)
Sz ject [Parallel Application]
~ & Process 0 (Suspended) t
~ o Thread [1] (suspended) )@ )
< MyMPIProject.c & =0 & outline R =
MPI_Init(Sargc, &argv); = B R e 7
+ find out process rank * o mpih
= WPI_Comm_rank(MPI_COMM WORLD, &my_rank); o stdioh
o st
+ find out number of processes 4 stringh
> | MPI_Comm_size(MPI_COMM_WORLD, &num_procs); o calc_pi(int, int) : void
© main(int, char#(]) : int
if (my_rank 1= 0) { ~
( D
& Console % 0 Memory| [2. Problems * 4 Bv riv =0
0 —
=]
I )
Writable Smar...sert 2 = ¢
PTP Tutorial 4-5




Process Sets (1)

+ Traditional debuggers apply operations to a single
process

+ Parallel debugging operations apply to a single process
or to arbitrary collections of processes

+ A process set is a means of simultaneously referring to
one or more processes

Module 4 PTP Tutorial 4-6

Process Sets (2)

+ When a parallel debug session is first started, all
processes are placed in a set, called the Root set

+ Sets are always associated with a single job
+ A job can have any number of process sets

+ A set can contain from 1 to the number of processes in
a job

Module 4 PTP Tutorial 4-7




Operations On Process Sets

+ Debug operations on the
Parallel Debug view
2 parallel Debug 3 il @ 22 ® 0 | [{d @y =8
tOOIbar alWays apply to the ORTE@sc07tutorial: default:job06gR
current set:

£) job02 oFH >+ + £
+ Resume, suspend, stop, 200
step into, step over, step ;
return » =)
. ~ £ MyMPIProject [Pargfel Application]
+ The current process set is 7 . gomns
listed next to job name < . Threpff{1] (suspended)
a|0ng with number of =1 main() testMPI.c:50 80489b0

processes in the set

+ The processes in process
set are visible in right hand
part of the view

Root set = all
processes

Module 4 PTP Tutorial 4-8

Managing Process Sets

+ The remaining icons in the toolbar of the Parallel
Debug view allow you to create, modify, and delete
process sets, and to change the current process set

Create set Remove

\ from set
/

3 Parallel Debug 52 o> R & 0 8 o> &y =08

ORTE@sc07tutorial: default:job06 - Root [4] \ Cha nge

@ loboz ol v v current set
%5 Debug & o D v eR Delete

< &3 MyMPIProject [Parallel Application] set

v & Process 0
< ® Thread [1] (Suspended)
= 1 main() testMPI.c:50 80489b0

Module 4 PTP Tutorial 4-9




Creating A New Process Set

Select the processes
you want in the set by

e 2 o> @ 22 ® 0 & o~ v =08

ORTE@sc07tutorial: default:job06 - Root [4]
Py

clicking and dragging,
in this case, the last
three

Click on the Create
Set button

Enter a name for the
set, in this case
workers, and click OK
You will see the view
change to display only
the selected processes

Module 4

— e

»: job06

~— Create a new set name

g 2

Please enter the new set name.

< &% MyMPIProject [§

¥ &2 Process 0 (St
v o Thread [1]
= 1 main()

[workers l

lel Debug 3 i3 22 0 8 oY
ORTE@scO7tu ault:job06 - workers [3]
£) job02 1w vr

¥ job06

PTP Tutorial 4-10

+

+

Stepping Using New Process Set

£ PTP Debug - MyMPIProject/src/MyMPIProject.c - Eclipse Platform - /home/beth/ecl/cpp0402/~/ews, = &% |3
Fle Edit Refactor Navigate Search Project Run Window Help
With the workers set | . B |5~ 0- @ @ O | = | - 5 »
active, click the Step _| i raeioens = 0| face v = s BalTe| =0
L default;job04 - workers [3 . <
Over button Bt e . el
L R Y # 0 | oy e e e Value
You will see only the iobo2 [ |
- . £ job04 7 =)
first current line =
%5 Debug % a
marker move =<
o " cati 3 D)
4 MyMPIProject [Parallel Application] S D)
If a” processe.s are now £ MyMPIProject [Parallel Application] i
at the same line, you - |
WI“ only See one Ilne [& MyMPIProject.c 52 = O|/E outline 2 =g
marker again U WI_tnit(sargc, sargy); o] BN e ®
| * find out process rank * = mpih
L MPI_Comm_rank (MPI_COMM_WORLD, &my_rank); o stdioh
| * find out number of processes ¥/ o stringh
» MPI_Comm_size(MPI_COMM_WORLD, &nhum_procs); © calc_pi(int, int) : void
= o mainint, chart{]) : int
I I D}
B Console 2 (J Memory [2. Problems ® G v =08
C-Build [MyMPIProject] -
make: Nothing to be done for ‘all'. H
2| 9 <

Module 4
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Process Registration

+ Process set commands apply to groups of
processes

+ For finer control and more detailed
information, a process can be registered and
isolated in the Debug view

+ Registered processes, including their stack
traces and threads, appear in the Debug view

+ Any number of processes can be registered,
and processes can be registered or
un-registered at any time

Module 4 PTP Tutorial 4-12

Registering A Process

,
+ TO reQISter a processl File Edit Refactor Navigate Search Run Project Window Help
double-click its process _ | - @ | 0o av O = | o = e

icon in the Parallel 2 parale
Debug view or Se|eCt a ORTE@sc07tutorial: default:j

> 2D ® 0 K o v = 0| B

£ job02 oFH» @ !
number of processes and Groups (sets) | ™"
click on the register of processes .
bUtton %5 Debug &8 b D v =8 :
+ The process icon will be < § MyMPIProject [Parallel Application] . °
- & Process 0 (Suspended) Individual b e
surrounded by a box and <  Thread (1] (Suspended) -

) (registered) b
the process appears |n = 1 main() testMPI.c:63 80489e0 processes

the Debug view ——— “¥7reieeee
+ To un-register a process, —
double-click on the [© testMPL.c 23 58 job05:0
process icon or select a
number of processes and
click on the unregister
button

Module 4 PTP Tutorial 4-13




Current Line Marker

+ The current line marker is used to show the
current location of suspended processes

+ In traditional programs, there is a single
current line marker (the exception to this is
multi-threaded programs)

+ In parallel programs, there is a current line
marker for every process

+ The PTP debugger shows one current line
marker for every group of processes at the

same location

Module 4

PTP Tutorial

Colors And Markers

+ The highlight color depends on
the processes suspended at
that line:

+ Blue: All registered process(es)

+ Orange: All unregistered
process(es)

+ Green: Registered or unregistered
process with no source line (e.g.
suspended in a library routine)

+ The marker depends on the

type of process stopped at that
location

+ Hover over marker for more
details about the processes
suspend at that location

Module 4

PTP Tutorial

[& testMPL.c 33 job05:0
tart u

MPI_Init(&argc, &argv);

ind out process rank *
o MPI_Comm_rank(MPI_COMM_WORLD, &my_rank);

ind ou N f C €
MPI_Comm_size (MPI_COMM_WORLD, &num_procs);

i€ (mu rank 1= @) f

B console 2 [ Memory | ©] Error Log| [£! Problems

% Multiple processes marker
» Registered process marker

» Un-registered process marker

% |Multiple markers at this line
-Suspended on unregistered process: 2
-Suspended on registered process: 1

4-15




Breakpoints

+ Apply only to processes in the particular set that is
active in the Parallel Debug view when the breakpoint
is created

+ Breakpoints are colored depending on the active
process set and the set the breakpoint applies to:

+ Green indicates the breakpoint set is the same
as the active set.

+ Blue indicates some processes in the breakpoint set are
also in the active set (i.e. the process sets overlap)

+ Yellow indicates the breakpoint set is different from the
active set (i.e. the process sets are disjoint)

+ When the job completes, the breakpoints are
automatically removed

] else{
) print:

J MPI_Final

Module 4 PTP Tutorial

+ Select the process set that

Creating A Breakpoint

2 Parallel Debug 52 B ® 2
ORTE@sc07tutorial: default:job06 - workers [3]
£ job02 |

#® 0 o ¢ @ @v =0 %Bre:

the breakpoint should apply .
to, in this case, the workers | === i
set

% d

+ Double-click on the left edge " [
of an editor window, at the
line on which you want to set
the breakpoint, or right click
and use the Parallel
Breakpoint» Toggle
Breakpoint context menu

+ The breakpoint on the call to
——

MPI Send()

Module 4

v &3 MyMPIProject [Parallel Application]
v & Process 3 (Suspended)

@t
bem

b & st

< ? Thread [1] (Suspended)

[ testMPLc & 28 job05:0
1T (my_ran {

reate messag
sprintf(message, *Greetings from process %d!*, my_rank);
+ use strlen+l so that jet transmitted +
’ MPI_Send(message, strlen(message)+l, MPI_CHAR,
dest, tag, MPL_COMM_WORLD);
} else {
printf(“Num processes: %\n*,num_procs);
for (source = 1; source < num_procs; source++) {
MPI_Recv(message, 109, MPI_CHAR, source, tag,

PTP Tutorial




Hitting t

+ Click on the Resume button

in the Parallel Debug view =

+ In this example, the three
worker processes have hit the
breakpoint, as indicated by
the yellow process icons and

the current line marker

Process 0 is still running as its
icon is green

Module 4

he Breakpoint

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK

File Edit Refactor Navigate Search Run Project Window Help
£y~ @ B 0v Qv O =4 G = @
% Parallel Debug. > 00 ® 0 & o~ @y = 0|%
ORTE@sc07tutorial: default:job06 - Root [4] 7
0 job02 o~ +» @ o
% job06
> Debygr® 0> 2D v =g
57 MyMPIProject [Parallel Application]
T < & process 3 (suspended) »
< 4 Thread [1] (Suspended: Breakpoint hit.) >
= 1 main() testMPI.c:70 8048a14 @n
v & Process 0
+© Thread [1] (Running)
(@
[g testMPL.c % £ job05:0
. if (my_rank !=0) {
- /¥ create message */
. sprintf(message, "Greetings from process %d!*, my_rank);
. /* use strlen+l so that '\@' get transmitted */
» MPI_Send(message, strlen(message)+l, MPI_CHAR,
. dest, tag, MPI_COMM_WORLD);
. } else {
printf("Num processes: %\n",num_procs);
- e fmmiieon o % e e emen. emai\ C
PTP Tutorial 4-18

More On Stepping

The Step buttons are only
enabled when all processes
in the active set are
suspended (yellow icon)
In this case, process 0 is still=
running

Switch to the set of
suspended processes (the

“=_PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK

£ Parallel Debug 52 o> 0

torial: default:job06 - Root [4]
0 jobo2 oFHr +@

® 0 K

File Edit Refactor Navigate Search Run Project Window Help

r3v W |3 Ov Qv | O~ 2%

workers set)

You will now see the Step
buttons become enabled

Module 4

2 parallel Debug 53 Te— .
ORTE@sc07tutorial: default:job06 - workers [3]
£ job02

¥ job06

@0 8

I

PTP Tutorial

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK.

e~

= B

o'~ @ = 0| %%

el
oy F @ & =0
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Breakpoint Information

+ Hover over breakpoint icon
+ Will show the sets this breakpoint applies to

+ Select Breakpoints view
+ Will show all breakpoints in all projects

9 Breakpoints $2 = Variables & Expressions =08

% BB g MY
™ & testMPI.c [line: 70] {job03:workers}

Module 4 PTP Tutorial 4-20

Breakpoints View

+ Use the menu in the breakpoints view to group
breakpoints by type

+ Breakpoints sorted by bregkpoint set (process
set)

9 Breakpoints £3 = Variables &% Expressions =g
R &# N BB 9T
v ¥ & workers I Show Full Paths

W & testMPI.c [line: 70] {job03:workers} 1 Breakpoints

oo Select Default Working Set... 02 Breakpoint Types
03 Breakpoint Working Sets
Working Sets... 4 Files
, Parallel Br
Sh lified N
[[J Show Qualified Names 6 Projects
I )7 Resource Working Sets
-8 Advanced...
Module 4 PTP Tutorial 4-21
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Global Breakpoints

+ Apply to all processes and all jobs
+ Used for gaining control at debugger startup
+ To create a global breakpoint
+ First make sure that no jobs are selected (click in white
part of jobs view if necessary)
+ Double-click on the left edge of an editor window

+ Note that if a job is selected, the breakpoint will apply to
the current set

%9

Module 4

if (my_rank !'=0) {
/¥ create message */
sprintf(message, "Greetin

PTP Tutorial 4-22

Terminating A Debug Session

+ Click on the Terminate

£ PTP Debug - MyMPIProject/testMPI.c - Eclipse SDK

File Edit Refactor Navigate Search Run Project Window Help

( _ B v ovav O = | o o (B
icon in the Parallel —Trmrremmr——— & o v @~ =001

Debug view to
terminate all processes
in the active set

+ Make sure the Root set
is active if you want to
terminate all processes

+ You can also use the
terminate icon in the

ORTE@sc07tutorial: default:job06 - Root [4] _
0 job02 EFEY l»

2 job06

%5 Debug 2 * v =0

£+ MyMPIProject [Parallel Application]

Debug view to
terminate the currently
selected process

Module 4

i parallel Debug % o> @ 2 # 0 K o v =08|[%B

ORTE@sc07tutorial: default:job06 - Root [4] -
job02 0 >99

. L

%

L %

%5 Debug 53 il 2 B v =g °

~ &3 MyMPIProject [Parallel Application] 9

~ & Process 0 (Suspended) °

< @ Thread [1] (Suspended) ﬁ*

= 1main() testMPl.c:63 80489e0

PTP Tutorial 4-23
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Module 5: Advanced Development

+ Objective
+ Explore advanced features of Eclipse and PTP

4+ Contents
+ Advanced Eclipse Features
+ Advanced PTP Features

Module 5 PTP Tutorial 5-0

Advanced Eclipse Concepts

+ Perspectives, views and preferences
+ Version control

+ Makefiles and autoconf

+ Task Tags

+ Searching

+ Refactoring

Module 5 PTP Tutorial 5-1




Customizing Perspectives

+ Items such as shortcuts, menu items and views may be
customized
+ Window» Customize Perspective...
+ Save changes
+ Window»Save Perspective As...
+ Close Perspective
+ Right-click on perspective title and select Close
+ Reset Perspective

+ Window» Reset Perspective resets the current
perspective to its default layout

Module 5 PTP Tutorial 5-2

Opening New Views

+ To open a view: @ showview B
+ Choose Window»Show View» Other... _
¥ (= General Rad
+ The Show View dialog comes up WRookmarks
. ¥ Classic Search
+ Select the view to be shown D Console
+ Select OK e B
5% Outline
[Z: Problems
CProgress L
Project Explorer
I Properties
¥ Search
v Tasks
P =Ant
Db =C/CH++ ]
[ o ][ coca |

Module 5 PTP Tutorial 5-3




Workbench Preferences

+ Preferences provide a way for you to
customize your Workbench

+ By selecting Window »Preferences... or
Eclipse» Preferences... (Mac)

+ Examples of preference settings

+ Use Emacs bindings for editor keys

+ Modify editor folding defaults
+E.g., fold all macro definitions

+ Associate file types with file extensions
+E.g., *.f03 with the Fortran editor

+ Toggle automatic builds

+ Change key sequence shortcuts
+E.g., Ctrl+/ for Comment

Module 5 PTP Tutorial 5-4

Version Control (CVS)

+ Version control provided through the Project
Explorer View, in the Team context menu

+ Provides familiar actions:

+ Commit...
+ Update...
+ Also less used tasks: ' &~

+ Create/Apply Patch...
+ Tag as Version

+ Branch...

+ Merge...

+ Add to .cvsignore... N

Module 5 PTP Tutorial 5-5




Specify Repository Locations

- JeXe) Add CVS Repository

+ Select Window»Open Add a new CVS Repository
Perspective > Other... oo tepese e e G Ry e cvs|
+ Select CVS Repository Exploring ===
then OK . :
+ Right-click in CVS Repositories
View, then select =
New » Repository Location... password
+ Set Host to the hostname of B — -
remote machine @ Lo
+ Set Repository path O use pore
+ Fill in Username and Password 7o
+ Set Connection type PRy e IR
+ Check Save password e
+ Select Finish
Module 5 PTP Tutorial 5-6
Checkout a non-Eclipse project as an
Eclipse C Project
+ Open Repository, open HEAD New >
Check Out

+ Locate project, right-click on

m—pp Check Out As...

Project»Check out As...

+ Make sure Check out as a project
configured using the New Project

Wizard is selected
+ Select Finish
+ Select C»C project
+ Select Next>
+ Enter Project name

+ Under Project Types, select Makefile

project
+ Ensures that CDT will use existing
makefiles

+ Select Finish

+ Switch to the C/C++ Perspective

Module 5

i@ Tag as Version...
Tag with Existing...
eno

Check Out As

8no

New Project

Select a wizard

Create a new C project

Wizards:
type filter text

Project types:

Cvs,

v

2% Java project
* )
Plug-in Project

roject from |

(= General

29 C Project

PTP Tutorial

> (= Executable

(= Shared Library

(= Static Library

<> Executable (XL C/C++)

< static Library(XL C/C++)
< Shared Library (XL C/C++)
(= Makefile project




About Makefiles and autoconf

+ Can create project Makefiles with the Makefile
Editor

+ Syntax highlighting and Outline view

+ autoconf often used to create Makefiles for
open source projects

+ Run configure manually, or from External
Tools Launch Configuration
+ Must refresh after running configure script

+ Refresh whenever file system is modified
outside of Eclipse

Module 5 PTP Tutorial 5-8

Building with Makefiles

& | EEic/C+4| EaCVs Repo...

+ Create a Make Target

named ‘a”’ = O Z= outline () Make Targets &3 =

+ Right-click on the 7 > &
project in Make gl 2 CVSEoled
Targets VieW D =5 MyMPIProject

reate a new Make targef E ; —
+ Select Add Make .
[arge lame: '—
Target feroeth
Make Target
+ Select Create

Make Target: |all / B
+ Double click on new ula command -
make target to initiate B e
the build Build Setting

Stop on first build error.

/| Run all project builders.

Create Cancel

Module 5 PTP Tutorial 5-9




Task

+ Task tags are identifiers in C/
C++ comments
TODO is a built-in task tag
The build locates task tags
during compilation
View task tags in Tasks View
+ If it’s not shown, Window
» Show View » Other...
Open General and select
Tasks
Configure your own task tag
in Window » Preferences
4+ Under C/C++, select Task
Tags
Module 5

PTP Tutorial

Tags

(&) MySamplepraject.c £

Gormsyine il -

#include <si

#ig
2]
“int maip(void) {
2] s
pUTSTE

return EXIT_SUCCESS;
¥

(]
<] m >
[21 problems | EJ console | = Properne
Filter matched 3 of 8 items
v ! Description Resource Path Location

MyTag a sample task tag MySamplePr... MySampleProject/src e 17
MyTag ke this MySamplePr... MySampleProject/src  line 8
TODO this is a built-in task tag MySamplePr... MySampleProject/src line 14

Searching

Language-based

searching

Search for Language

Elements

+ e.g., C++ Class,
Function, Method,
Variable, Field,
Namespace

Can Limit search to

Declarations, Definitions,

References

+ Type navigation

Module 5

PTP Tutorial

—
, File Search | %7C/C++ Search

Search string (+ = any string, 7 = any character):
v | [J Case sensjtive

Search For Limit To

[] Class /Struct [ Function [ Variable > Declarations () Definitions

CJ Union [ Method (] Feld O References ® All Occurrences
] Enumeration (] Enumerator [] Namespace

[ Typedef [ /Any Element]

Scope:

@ Workspace

Working set: | choose...

@ |customize... | cancel
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UPC Support

Select the features to install:

) v <] TutorialcD/updatesite

v CDT 4.0.3.200802251018
“J* Eclipse C/C++ Development Tools SDK 4.0.3.200802251
(§* Eclipse C/C++ GDB Hardware Debugging 4.0.3.2008022°
el 51018

" &> nified Parallel C Support £).3.200802251018
3 PPort 4.0.3.200802251018
L Eclipse CDT Testing Feature 4.0.3.200802251018
» 100 Parallel Tools Platform 2.0

: w - fE MatrixMulti.upc &3 ).
+ Flletypes Of upc WI” L@m‘,‘r,)ah variables

get UPC syntax high-

H H H / the matrix a[][]
lighting, content assist, oy i ires Sa[iI[6D
etc. 3 <P; j++)
a[iJ[J]=1*P+]j+1;

+ To see UPC support in C
editor, install the optional
feature from CDT —_—

intialize the matrix b[][]
upc_forall(j=0; j<M; j++; &b[9][31D
for (i=0; i<P; i44)
b[1][3]-3%2;

Module 5 PTP Tutorial 5-12

Refactoring

+ Source-to-source transformation that
preserves behavior

+ Rename
+ Select C/C++ Perspective
+ Open a source file
+ Click in editor view on declaration of a variable
+ Select menu item Refactor» Rename
+ Or use context menu
+ Change variable name
+ Notice that change is semantic not textual

l = C/C++ - MyCproject/src/MyCproject.
File Edit | Refactor

x

— Rename.’.. Alt+Shift+R i

Navigate Search Proje

Module 5 PTP Tutorial 5-13




[l

int main(void) {

800 double intva

Refactoring

Source
Refactor

The following changes are necessary to perform the refactoring.

Changes to be performed
™ v & Changes
4 @5 MyCproject.c - MyCproject/src

Declarations

—

‘ Refactored Source
#include <stdlib.h>

€ MyCproject.c

ot W

@A

Original Source
#include <stdio.h>
#include <stdlib.h>

Tnt main(void) {
double intvnluo
puts("111Hello N9 -

return EXIT_SUCCESS;

__{Static const float MYZERO = 0.0; ]
[int main(void) { ]
double intvalue-MYZERO;
puts("I11Hello florld!117); /% pri
return EXIT_SUCCESS;

lue-al.(bt
SEN| |
> Rename... 4XR
> Extract Constant... XC
A b

DT 5.0 will be available
in the Eclipse “"Ganymede”
release, June 2008

| + Other refactorings that
are planned:

Extract Function

Hide Member Function

Move Field or Member Function
Extract Subclass

Extract Baseclass

Separate Class

Implement Function

Declare Function

Move Function Definition

R R

} } 8
int foo(Q{ int foo(){
double mym double myint-MYZERO;
} }
| | :
@ < Back Nex Cancel Finish )
Module 5 PTP Tutorial

Generate Getters and Setters
5-14

Advanced PTP Concepts

+ Remote resource managers
+ Debugging remotely

+ MPICHZ2, IBM PE and LoadLeveler

Module 5 PTP Tutorial
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Remote Resource Manager

Select Remote Tools as the
Remote service provider

\W"ec( to an ORTE proxy server
Click New... to create a new

location

Enter a Target Name, IP
address or host name of the
remote machine, and
credentials

Select Finish

Select the Target Name you
just created for Proxy
server location if it is not
visible in the dropdown

Module 5

[l

8,00

ORTE Proxy Configuration

Remote service provider: | Remote Tools s ]
Proxy server location: Remote TTosT mp New...
4
Path to proxy executable: x.x86/bin/ptp_orte_proxy Browse € Options...
Multiplexing Options
(@ None 8.0.0, A Wigural
Remote Host o
Local addre PePenies for connecting to  remote host 3
py Target name: [VeryBigCluster 7
~ Use pO’t fe Host Information
- O Localhost @ Remote host
[Jlaunch serve o o3zaser — lem 2 |
User: [greg
@ Password based authentication
Password: [seeee 4
O public key based authentication
= File with private key: Browse ) | —————— —
@ Cancel Finish
Passphrase: —_— Y
( Advanced )
PTPT @ (Gl ) () 5-16

Select Proxy Agent

Click Browse to select
the proxy server
executable

Open Root twisty

Now navigate to and
select the proxy
executable

Click OK

Module 5

800

ORTE Proxy Configuration

information to connect to an ORTE proxy server

Remote service provider: Tools

—
[ VeryBigCluster

x.x86/bin/ptp_orte_proxy

8,00 Browse File /

1 Select file:

Proxy server location:

\g]

(" Browse

Path to proxy executable: Options... )
Multiplexing Options

(® None

Local address

/Users/greg/Documents /workspaces/ptp_t

() Use port forw:
» (= org.eclipse.ptp.macosx.pp
v (= org.eclipse.ptp.macosx.x8
[ -project
@ abouthtmi
v (& bin 0
cusignore
> Vs
“ ptp_mpich2_proxy
- Pptp_orte_proxy T )
@ “= piplib.py Cancel
README 1

"I Launch server m

(" Finish

sdm

[ ] Ty

Cancel

o)
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Using

+ Port forwarding can be
enabled to tunnel all
communication over a
single connection

+ If you don’t want to us
port forwarding, your
local machine must be
accessible from the
remote machine

+ Select your local machine’s
IP address from the
dropdown

+ Enter it manually if it's not
visible

+ Click Finish

Module 5

Port Forwarding

800
ORTE Proxy Configuration

Enter information to connect to an ORTE proxy server

Remote service provider: | Remote Tools m
Proxy server location: local 2 New...
Path to proxy executable: x.x86/bin/ptp_orte_proxy _ Browse _ Options...

Multiplexing Options.
0O
(O None
Local address for proxy connection: 9.67.154.242 v

() Use port forwarding

aunch server manually

@ < Back Next > Cancel ( Finish \

PTP Tutorial 5-18

Debu

gging Remotely

8.0.0 Debug

+ Choose remote resource
manager in Main tab

+ Click Browse and select |~

sdm executable on ~
remote machine (if path
is not correct)

+ Set Debugger session
address to the address
of the machine running
the proxy agent

+ The address must be

accessible from a cluster
node

+ Click Finish

Module 5

Create, manage, and run configurations P
SR N ) OS-
Create a configuration to launch a parallel application in Parallel Debug Perspective "Q\

Name: shallow2

filter text . _ i, .
) Main [§} Resources [%5 Debugger )\ ®= Arguments | i/ Source| 2
57 Java Applicati )

Ju JUnit
Jt Junit Plug-in Test
4 0SGi Framework
£-} Parallel Application Debugger Options
& debug fail

™ Stop at main() on

Path to debugger executable:

/home/greg/ptp/plugins/org.eclipse.ptp.linux.x86_2 Browse

Debugger session address:

cluster_head

Apply _ Revert

Filter matched 19 of 19

PTP Tutorial 5-19
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Alternate Resource Managers

+ An MPICH2 resource manager is provided
+ Use ptp mpich2 proxy when selecting proxy executable
+ PE and LoadlLeveler

+ See help documentation that comes with PTP for
information on configuring and using

+ Debugging support for alternate resource managers will
be available in next version of PTP

Module 5 PTP Tutorial 5-20
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Module 6: Where To Go Next

+ Objective
+ How to find more information on PTP
+ Learn about other tools related to PTP
+ See PTP upcoming features
+ Contents
+ Links to other tools, including performance tools
+ Planned features for new versions of PTP
+ Additional documentation
+ How to get involved

Module 6 PTP Tutorial 6-0

Information About PTP

+ Main web site for downloads, documentation, etc.
+ http://eclipse.org/ptp
+ Developers’ wiki for designs, planning, meetings, etc.
+ http://wiki.eclipse.org/PTP
+ Mailing lists
+ Major announcements (new releases, etc.) - low volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-announce
+ User discussion and queries - medium volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-user
+ Developer discussions - high volume
+ http://dev.eclipse.org/mailman/listinfo/ptp-dev
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PTP-Related Tools

+ Performance Tools Framework

+ Tuning and Analysis Utilities (TAU)

+ TuningFork - Performance Visualization
+ Photran - Fortran Development Tools
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PTP / Performance Tools
Framework -

Goal:

+ Reduce the “eclipse plumbing”
necessary to integrate tools

+ Provide integration for
instrumentation, measurement, and
analysis for a variety of performance
tools

+ Dynamic Tool Definitions:
Workflows & Ul

+ Tools and tool workflows are
specified in an XML file

+ Tools are selected and configured in
the launch configuration window

+ Output is generated, managed and
analyzed as specified in the
workflow
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PTP TAU plug-ins we %
www.cs.uoregon.edu/research/tau/home.php

+ TAU (Tuning and Analysis Utilities)
+ First implementation of Performance Tools Framework

+ Eclipse plug-ins wrap TAU functions, make them
available from Eclipse

+ Compatible with Photran and CDT projects and with
PTP parallel application launching

+ Other plug-ins launch Paraprof from Eclipse too
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TuningFork

+ http://www.alphaworks.ibm.com/tech/tuningfork

+ Performance visualization Eclipse plug-ins from
IBM Research

+ Rich Client Platform; IDE version in progress

+ Designed for real-time visualization of large
data sets ‘ =

+ Will be available open }
source on Source Forge

+ Enhancements for parallel ‘I I
computing underway N Ii
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+ 4+ 4+ 4+ +

+ 4+ ++

Photran

Supports Fortran in
the Eclipse workbench
Supports Fortran 77, 90,

and 95
It includes:

Syntax-highlighting editor
CVS support
GUI interface to gdb

Makefile-based
compilation

Compiler error extraction
Outline view
Open declaration

Rename and Introduce

Implicit None refactorings
Module 6

http://eclipse.org/photran
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Useful Eclipse Tools

+ Python

+ http://pydev.sourceforge.net

+ Subversion (CVS replacement)
+ http://subclipse.tigris.org
+ Now an Eclipse Technology project

+ ... and many more!
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Future PTP Features

+ Resource manager support for SLURM, PBS,
LSF, BG/P

+ Simplified runtime system interface (plus
support for other MPI runtimes)

+ Debugging support for a broad range of
architectures

+ Full remote project support (combined with
CDT)
+ Remote build and indexing
+ Remote launch/debug

+ Performance analysis tools integration
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PTP Publications

+ "Developing Scientific Applications Using Eclipse,” Computing
in Science & Engineering, vol. 8, no. 4, July/August 2006, pp.
50-61

+ Link on http://eclipse.org/ptp web page

+ "A Model-Based Framework for the Integration of Parallel
Tools”, Proceedings of the IEEE International Conference on
Cluster Computing, Barcelona, September 2006

+ Link on http://eclipse.org/ptp web page

+ IBM developerWorks article:

+ http://www-128.ibm.com/developerworks/edu/os-dw-os-ecl-ptp.html

+ “An Integrated Tools Platform for Multi-Core Enablement,”
Beth Tibbitts & Evelyn Duesterwald, STMCS: Second
Workshop on Software Tools for Multi-Core Systems, March
2007

+ http://www.isi.edu/~mhall/stmcs07/program.html
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Getting Involved

+ See http://eclipse.org/ptp
+ Read the developer documentation on the wiki
+ Join the mailing lists

+ ptp-dev@eclipse.org; ptp-user@eclipse.org
+ Attend the monthly developer teleconference
+ Attend the annual workshop

+ PTP will only succeed with your participation!
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PTP Tutorial Feedback

+ Please complete feedback form
+ Your feedback is valuable!

Thanks for attending
We hope you found it useful
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